Deployment Framework 7 release highlights

The Caplin Deployment Framework 7 includes new support for IPv6 and has a lighter design.

For guidance on upgrading to the Deployment Framework 7, see Upgrading to Caplin Platform 7.

Contents:

New features

The Deployment Framework 7 has the following new features:

Support for IPv6

The Deployment Framework has been updated to work with IPv6.

Support for modules written using the Java Transformer Module API 7

The Deployment Framework recognises modules written with the new JTM API, com.caplin.jtm.

Lighter design

The following files have been removed from the Deployment Framework and are now packaged with Liberator and Transformer:

  • Built-in configuration blades.
    • Examples of blades that have been removed: kits/LiberatorWebsite, kits/TransformerJMX
  • Configuration override files.
    • Examples of override files that have been removed: global_config/overrides/servers/Liberator/etc/rttpd.conf, global_config/overrides/servers/Transformer/etc/pipeline.conf

More accessible Java configuration

The Java virtual machine (JVM) configuration options in Caplin Platform 7 blades have been moved to the blades' override files.

Transformer to Liberator connection configuration

The configuration for the connection between Transformer and Liberator has been removed from the Deployment Framework and is now packaged with Transformer as two configuration blades: TransformerToLiberatorConnection and TransformerToLiberatorSSLConnection. To customise the connection between Transformer and Liberator, create your own configuration blades based on the design of TransformerToLiberatorConnection and TransformerToLiberatorSSLConnection.

Cross-platform deployment of blades

The Deployment Framework now supports cross-platform deployment of blades that a built for a specific operating system. Previously, if a blade was built for a different operating system than the Deployment Framework's host, then the blade would fail to deploy. Now, such a blade is deployed as a configuration-only blade.

Developers who work on Windows or macOS can now easily deploy the configuration contained within blades that are built for Linux.

New command: support

The Deployment Framework includes a new command, support, that collates core information required by Caplin Support:

  • Log files
  • Configuration
  • Deployed components and their versions (output of the versions command)
  • Network ports (output of the info command)

Compatibility

All Caplin Platform 7 components must be deployed on the Deployment Framework 7.

Liberator 6.2 and Transformer 6.2 cannot be deployed on the Deployment Framework 7.

Integration adapters written using DataSource 6.2 APIs can be deployed on the Deployment Framework 7.

Compatibility matrix
  Deployment Framework 6.2 Deployment Framework 7
Liberator 6.2
Transformer 6.2
Adapters (DataSource 6.2)
Liberator 7
Transformer 7
Adapters (DataSource 7)

See also: