Upgrading Transformer

The page provides instructions on upgrading an existing installation of Transformer, and should be read in conjunction with Installing Transformer.

If you are upgrading from Transformer 6.2 to Transformer 7, see Upgrading to Caplin Platform 7.

Contents:

Requirements

Transformer 6.2 must be deployed on Deployment Framework 6.2.

Transformer 7 must be deployed on Deployment Framework 7.

Upgrade Transformer

Note: You cannot use these instructions to upgrade Transformer 6.x to Transformer 7. See Upgrading to Caplin Platform 7.

To upgrade an existing installation of Transformer, follow the instructions below.

  1. Stop all components running under the Deployment Framework:
    1. ./dfw stop
  2. Copy the Transformer installation file to <Framework-root>/kits
  3. Deploy the new version of Transformer:
    1. ./dfw deploy
    2. As part of deployment, the Deployment Framework copies configuration-override files for the new version of Transformer to the <Framework-root>/global_config/overrides/Transformer directory. Existing configuration-override files are not overwritten. When a file cannot be copied because an older version of the file already exists in the <Framework-root>/global_config/overrides/Transformer directory, the Deployment Framework prints a warning to the console.
  4. Confirm the new version of Transformer has deployed correctly:
    1. ./dfw versions
  5. If any configuration override files failed to copy in step 3 above, compare the current override files with the override files from the newly deployed Transformer, and manually update the current configuration override files.
    1. See the release notes for the new version of Transformer to learn about new configuration items included in the new version.
    2. The current configuration override files for Transformer can be found at <Framework-root>/global_config/overrides/servers/Transformer/etc. This directory will include override files that were not overwritten by the override files from the new release of Transformer.
    3. The configuration override files for the newly deployed version of Transformer can be found at <Framework-root>/kits/Transformer/Latest/etc/overrides
  6. Restart the Deployment Framework
    1. ./dfw start

Upgrade a Transformer Module

Note: You cannot use these instructions to upgrade a module from version 6.2 to 7. See Upgrading to Caplin Platform 7.

Before upgrading a module to a new version, check the release notes to confirm that the new version is compatible with the other components in your deployment.

To upgrade a Transformer module, follow the instructions below.

  1. Stop all components running under the Deployment Framework:
    1. ./dfw stop
  2. Copy the module installation file to <Framework-root>/kits
  3. Deploy the new version of the module:
    1. ./dfw deploy
    2. As part of deployment, the Deployment Framework copies configuration-override files for the new version of the module to the <Framework-root>/global_config/overrides/<module_name> directory. Existing configuration-override files are not overwritten. When an override file cannot be copied because an older version of the file already exists in the <Framework-root>/global_config/overrides/<module_name> directory, the Deployment Framework prints a warning to the console.
  4. Confirm the new version of the module has deployed correctly:
    1. ./dfw versions
  5. If any override files failed to copy in step 3 above, compare the current override files with the override files from the newly deployed module, and manually update the current configuration override files.
    1. See the release notes for the new version of the module to learn about new configuration items included in the new version.
    2. The current configuration override files for the module can be found at <Framework-root>/global_config/overrides/<module_name>. This directory will include files that were not overwritten by the override files from the new release of the module.
    3. The configuration override files for the newly deployed version of a module can be found at <Framework-root>/kits/<module_name>/Latest/etc/overrides
  6. Restart the Deployment Framework
    1. ./dfw start